Not compatible with NoScript Rated 3 out of 5 stars

This would be a fantastic add-on -- if it were made compatible with the NoScript add-on, and if the printing bug was fixed.

Here's hoping for an update!

This review is for a previous version of the add-on (1.0.6.1-signed.1-signed).