Still not working Feb 2013 Rated 1 out of 5 stars

Running FFox 18.0.2, says errmsg "Sorry, you need a Mozilla-based browser to install.." LOL!