Integrated Authentication for Firefox Version History

8 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 3.0.1 170.5 kB Works with Firefox 29.0a1 and later

Totally rewritten to use the Add-On SDK to support FF29+.

Version 2.0.2 25.8 kB Works with Firefox 13.0 and later

Includes minor performance improvements and a fix for an issue reported where a user lost some of the sites in their authentication list.

Version 2.0.1 25.6 kB Works with Firefox 13.0 and later

Minor fixes to remove some errors at runtime. Increased compatibility version info.

Version 2.0.0 25.6 kB Works with Firefox 13.0 and later

You can now add sites to the list of pass-through sites by specifying just the domain or host name without a protocol as outlined by the Mozilla spec.

Support has also been added so you can toggle the network.automatic-ntlm-auth.allow-non-fqdn and network.negotiate-auth.allow-non-fqdn configuration keys, allowing automatic pass-through auth for all non-FQDN hosts without having to specify every one explicitly. These settings are new in Firefox 13.

Version 1.2.0 56.3 kB Works with Firefox 3.0 and later

Version 1.2.0 adds configuration for other integrated authentication protocols that Firefox supports (e.g., Kerberos). Rather than just setting the NTLM/Windows configuration value, it now updates all three configuration settings:

  • network.automatic-ntlm-auth.trusted-uris
  • network.negotiate-auth.delegation-uris
  • network.negotiate-auth.trusted-uris

Also, this version adds an entry into the "Options" menu on the App Toolbar for Firefox 4.

Version 1.0.5 21.5 kB Works with Firefox 3.0 and later

Minor fix for FF4.0.* compatibility: Removed unused code for debug logging since console access has changed in FF4. Updated install.rdf to have 4.0.* support.

Version 1.0.4 21.5 kB Works with Firefox 3.0 and later

Updated compatibility to 4.0b6pre. Renamed to "NTLMAuth for Firefox" per developer relations request.

Version 1.0.3 21.5 kB Works with Firefox 3.0 - 4.0b5pre

Updated to support Firefox 3.6.