Not able to install with new FF Rated 1 out of 5 stars

Needs to be upgraded.....
Disappointed.