Rated 1 out of 5 stars

The big problem is that the current ImTranslator has not yet compatible with the latest release of Firefox : 3.5.2
I can't advice to install it

This review is for a previous version of the add-on (3.2.9). 

ImTranslator works with Firefox 3.5.2

ImTranslator is compatible with Firefox: 1.0 – 3.6a1pre.