Rated 1 out of 5 stars

Well I\'ve selected every \'older version\' that is listed but it seems image fetcher is only compatible with FF3. Pity we weren\'t told that.

This review is for a previous version of the add-on (0.2.1).