Well . . . Not yet rated

Would love to try it but I have the same problem as typoguy. Image Fetcher asks me to upgrade but I am already using FF 2.0.0.13.

This review is for a previous version of the add-on (0.2.1).