No longer works with Firefox 57, using Kantu now Rated 5 out of 5 stars

As much as I like the new Firefox, I will miss this addon.

This is not a bug that can be fixed. Firefox 57 is the first version of Firefox that only allows modern WebExtension addons, so iMacros as powerful XUL-based addon no longer runs.

As alternative I switched to the Kanto extension, but it is not available for Firefox yet, only Chrome.

This user has a previous review of this add-on.