Incompatible with Fx8 Rated 4 out of 5 stars

Used this one often, in fact, wouldn't have installed Firefox 8 had I known this version was incompatible.

This review is for a previous version of the add-on (1.4.5.1). 

It *is* compatible, actually

And noted as such here... but Firefox has trouble noticing that the compatibility details have been updated, particularly right after a major release when the servers are busy. If you remove the add-on and reinstall from here, all should be fine (even though nothing has really changed).

I've uploaded a 1.4.5.2 version just to kick Firefox into grabbing the update, but it's not yet approved.