Works well Rated 4 out of 5 stars

I use this extension regularly since there are still so many IE specific sites out there. Notwithstanding the Seamonkey 2.2 warning it works fine there. Just use the About:Config trick of adding a new false boolean called extensions.checkCompatibility.2.2

This review is for a previous version of the add-on (1.4.5.1).