it didn't work now with FF17.0.1 ... Rated 1 out of 5 stars

Hello,

it didn't work now with FF17.0.1 ...
Every time I want to use it to go to my professional secure webmail, it freeze all FF ... sometimes, want you wait a few moment, FF are useable BUT in general, I must to kill the processus plugin-container.exe to come back on a "normal" use without IE Tab !

Could you, please, make something about that problem ?

Thx and have a nice 2013 all year !

This review is for a previous version of the add-on (2.0.20120203). 

A brand new release is currently under review.

We have a new release 4.0. It's already submitted to AMO and is currently under review. It should support the latest firefox and fix the crashes. Thank you.