Rated 2 out of 5 stars

"Missing plugin" error prevents use. Updating or backdating IE to any version doesn't fix the error, though I doubted it would as you continually say IE doesn't matter for the plugin.

This review is for a previous version of the add-on (2.0.20120203).