Rated 1 out of 5 stars

This is a dead-end for all FF 3.6+ versions. I stayed with FF 3.5.9 hoping that this excellent and trouble-free add-on would be updated, but it is not going to be. AVOID the "Coral IE Tab"-- it does have more features but does malfunction in some configurations. Not worth the hassle. I have finally installed "IE Tab 2", which works EXACTLY the same as the original IE Tab (different developer updated the old code). No problems in FF 3.5.9 and now in FF 3.6.3. So long, Hong Jen Lee, it was nice knowin' ya.

This review is for a previous version of the add-on (1.5.20090525).