Needs Updated Rated 5 out of 5 stars

this is an awesome extension but its now getting closer and closer to a year without a single update. were closer and closer to the final firefox 3.0 stage and this is still only compatible up to the alpha 5 stage. are we gonna this ever upgraded to firefox 3.0 rather than stuck on alpha5?

This review is for a previous version of the add-on (1.3.3.20070528).