Rated 4 out of 5 stars

It didn't work even with me.please upgrade for FF 3.6

This review is for a previous version of the add-on (1.5.20090525).