Rated 5 out of 5 stars

@johnspac:
It does. Make sure, you have "extensions.checkCompatibility" and "extensions.checkUpdateSecurity" prefs set to "false".

This review is for a previous version of the add-on (1.5.20090207).