Compatible version range has been fixed : it is now working again on Firefox 52.x ESR Rated 4 out of 5 stars

Thanks to some Mozilla employees and a developer of IETab, this addon is now marked as compatible with Firefox ESR 52.x (as it should have been from the beginning). See https://bugzilla.mozilla.org/show_bug.cgi?id=1369516
It is very useful in some companies with internal sites using ActiveX (which becomes rare). I've been using and deploying it for a while with earlier versions of Firefox. I did not see any issue after using it a few weeks on ESR 52.1.2.
But be aware that you won't have any support on it (AFAIK), and that it won't work any more on Firefox ESR >=59 (and it's already not working on Firefox RR>=52)