IE Tab v2 is NOT working with Firefox v52.1.1 ESR Rated 5 out of 5 stars

Confirmed IE Tab v2 is NOT working with Firefox v52.1.1 ESR.
It has been deactivated by Firefox.

This user has a previous review of this add-on.