doesnt seem to work well on 64 bit version of firefox Rated 2 out of 5 stars

I have the latest version of 64 bit firefox and tried using this ext for google hangouts. It just displays plug in required. however when i select open ext app, it opens explorer 10 and Im able to hangout. trying to avoid using chrome by any means necessary