it's dead Rated 1 out of 5 stars

using firefox 64bit 49.0.2
stuck on "a plugin is needed" page