Forget the debate on the license. It works! Rated 5 out of 5 stars

The facts are that IE Tab V2 4.1.3.1 is working very well with Firefox 9.0.1 and that the original IE Tab is -at the moment- not compatible with Firefox 3.6-9.

This review is for a previous version of the add-on (4.1.3.1).