Perfect Rated 5 out of 5 stars

This works great with Ubuntu GNOME 14.04 LTS (GNOME 3.10) and FireFox 29

This review is for a previous version of the add-on (2.10.1-signed).