Rated 1 out of 5 stars

Sadly this no longer works and the developer will not answer any of the emails I have sent enquiring about it. It used to be very useful when it DID work. I wish it would work again as I cannot find anything else like it.

Rated 5 out of 5 stars

Please update for Firefox 3.6

Rated 5 out of 5 stars

i love it it's very good for ever day use on the internet.

Rated 5 out of 5 stars

I love it! BUT...when will there be a version compatible with FF 3.5? This is one reason I haven't upgraded to FF 3.5 yet - no kidding.

Working Rated 5 out of 5 stars

Much necessary for web surfers !!!!!!!!!11

Love it ! Rated 5 out of 5 stars

Great little utility !

Show ISP if no rDNS Rated 3 out of 5 stars

Where there is no reverse host lookup it would be more useful to display the owner of the IP block, hopefully the users' ISP, rather than just the IP address again.

This review is for a previous version of the add-on (0.4.3.8). 

Rated 4 out of 5 stars

Good stuff. All I miss is a little statusbar icon to temporarily switch its display off - in some situations it can get nasty ;)

This review is for a previous version of the add-on (0.4.3.8). 

Rated 4 out of 5 stars

if have data for China, it may be more better:
ip to hell
cz88.net

This review is for a previous version of the add-on (0.4.3.8). 

handy Rated 4 out of 5 stars

works fine here, good to know where you're going before you get there


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 - Build ID: 2008070208

This review is for a previous version of the add-on (0.4.3.8). 

Rated 1 out of 5 stars

It doesn't work on the current Firefox browser. I guess it works on older less secure Firefox. Why would developers like Matt and Brad not want to use the FF3.0.1? They prolly prefer Safari or IE or Opera :(

This review is for a previous version of the add-on (0.4.3.8). 

Oooops Rated 2 out of 5 stars

No...it does not work with all versions of FF. That's why it says it works with version up to 3.0b3. It will not install on 3.0b4

This review is for a previous version of the add-on (0.4.3.5). 

Doesn't Work!!! Rated 2 out of 5 stars

Hey!, i will really appreciate if someone help out,the extention doesn't work, when i click OPTIOS (for the extention), i get an XML error, i have Java Runtime Environment 1.6 Update 1, also i have Java, n JavaScript on, at the Firefox's options, i really dont' know why, but, i am open to suggestions, Please email me at miguel907gtr@gmail.com, thanks. :-)

This review is for a previous version of the add-on (0.4.3.3).