Great, Unless... Rated 3 out of 5 stars

... you're using Firefox 4, in which case it does not work (for me, at least). Worked great with Firefox 3.x.

This review is for a previous version of the add-on (1.0.1-signed). 

The add-on has recently been updated to support Firefox 4. Please let us know if you are still experiencing any issues.