Rated 1 out of 5 stars

It doesn't work with Firefox 3.5+ like it is stated it does.

The install.rdf shows it only supports 3.0.*
em:maxVersion="3.0.*" />

This review is for a previous version of the add-on (0.9.5).