HeadingsMap Version History

18 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 3.1.2 43.8 KiB Works with Firefox for Android 58.0a1 and later, Firefox 58.0a1 and later

Fix bug that prevented from adding new mutation observer after being removed

Version 3.1.1 43.8 KiB Works with Firefox for Android 58.0a1 and later, Firefox 58.0a1 and later

Version 3.1.0 43.9 KiB Works with Firefox for Android 58.0a1 and later, Firefox 58.0a1 and later

* Allow to collapse headers
* Improve how options behave
* Minor fixes and code refactor

Version 3.0.0 44.4 KiB Works with Firefox for Android 58.0a1 and later, Firefox 58.0a1 and later

Version 2.1.1-signed.1-signed 72.4 KiB Works with Firefox 1.5 - 56.*

Better support for HTML 5 Outline.

Version 2.0.9.1-signed.1-signed 72.4 KiB Works with Firefox 1.5 - 29.0

Version 2.0.5.1-signed.1-signed 60.5 KiB Works with Firefox 1.5 - 25.*

Version 2.0.2.1-signed.1-signed 60.0 KiB Works with Firefox 1.5 - 22.*

Fixing bugs

Version 2.0.1.1-signed.1-signed 57.4 KiB Works with Firefox 1.5 - 19.0a1

Fixed a bug on preferences set

Version 2.0.1-signed.1-signed 59.9 KiB Works with Firefox 1.5 - 15.*

Added Outliner for HTML 5.
Now you can copy (to paste) the headings structure.

Version 1.05.7.1-signed.1-signed 67.3 KiB Works with Firefox 1.5 - 15.*

Version 1.05.6 87.0 KiB Works with Firefox 1.5 - 3.7a1pre

Version 1.05.5 86.0 KiB Works with Firefox 1.0+ - 3.7a1pre

New option: If the first heading level is not 1, you can choose if this is an error or not.
Solved one bug in the heading selection when there are FRAMEs

Version 1.05.3 85.0 KiB Works with Firefox 1.5 - 3.6a1pre

New languages and new options

Version 1.05.2 87.0 KiB Works with Firefox 1.5 - 3.1b3pre

New icons and languages. In the previous version, there was a problem when the documet are XHTML served as "application/xhtml+xml". This version solve it.

Version 1.05.1 64.0 KiB Works with Firefox 1.5 - 3.0.*

Version 1.05 40.0 KiB Works with Firefox 1.5 - 3.0.*

Now, there are some options to choose if we want to see where are the Iframes in the list and the errors in headings levels, to change the styles, etc. Before this version, these things were by default. We can access to the options by clicking with the secondary button in the sidebar.

Version 1.0 11.0 KiB Works with Firefox 1.5 - 3.0pre