Firefox 3.6 Rated 4 out of 5 stars

Seems to work in FF 3.6 final, but the maxVersion is set to 3.6a1pre, which tells Firefox it is not compatible. Workaround is to download the xpi, extract (unzip) it, modify the install.rdf file and change the maxVersion to 3.7 or something. Then install it from the hard drive. Haven't had any problems yet.

This review is for a previous version of the add-on (0.1.5).