Rated 4 out of 5 stars

Pls help to update this to support FF7!

Firefox 4 support Rated 4 out of 5 stars

Yes pls help with firefox 4!

This review is for a previous version of the add-on (1.0.3).