Rated 4 out of 5 stars

It was working great until a few days ago. Now I get this message instead of a translation:

Suspected Terms of Service Abuse. Please see http://code.google.com/apis/errors

This review is for a previous version of the add-on (0.8.1-signed).