Grooveshark Unlocker Version History

13 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.4.1-signed.1-signed 56.6 kB Works with Firefox 4.0 and later

New: works without proxy (much more reliable)! But can still use one if the method without the proxy gets blocked.

Version 1.3.6.1-signed.1-signed 56.2 kB Works with Firefox 4.0 and later

- Proxy list gets updated right before visiting Grooveshark
- Added new proxy sources

Version 1.3.5.1-signed.1-signed 56.3 kB Works with Firefox 4.0 and later

Grooveshark Unlocker can now switch the proxylist source if one of them becomes unavailable.

Version 1.3.4.1-signed.1-signed 56.0 kB Works with Firefox 4.0 and later

Reliability update.

New features:
- Detects faulty proxies and automatically reloads page
- Supports deeplinks to songs, playlists, etc.

Version 1.3.2.1-signed.1-signed 34.2 kB Works with Firefox 4.0 and later

Fixed a bug where the proxy list contains only transparent proxys, which reveal the actual ip adress.

Version 1.3.1-signed.1-signed 34.1 kB Works with Firefox 4.0 and later

Added support for Grooveshark Retro (Classic Grooveshark page).

Version 1.2.1-signed.1-signed 34.1 kB Works with Firefox 4.0 and later

- New Feature: fetches latest proxy list from the web

No need to refresh the page anymore to bypass the protection

Version 1.1.2a.1-signed.1-signed 14.6 kB Works with Firefox 3.5 and later

- Proxy list updated
- Minor bugfix

Version 1.1.2.1-signed.1-signed 14.6 kB Works with Firefox 3.5 and later

Added new proxies.

Version 1.1.1.1-signed.1-signed 14.5 kB Works with Firefox 3.5 and later

Fixed bug where a proxy could stay after the loading of Grooveshark.

Add-on is based on the old version until I have found a fix for this, so you have to press F5 again several times to bypass the protection.

Version 1.1.1-signed.1-signed 15.7 kB Works with Firefox 4.0 and later

New Features:

- No need to hit F5 anymore to bypass the protection
- New proxies
- Localization for Germany added

Version 1.0.1.1-signed.1-signed 12.6 kB Works with Firefox 3.5 and later

Now uses different proxies on each page load to prevent overload of a single proxy.

Security issue fixed, where a proxy could stay in the settings when Firefox was closed before the proxy was disabled. As a precautionary measure the proxy setings are reset with every Firefox lauch. Therefore you cannot use the addon if you always use a proxy.

Version 1.0.1-signed.1-signed 12.2 kB Works with Firefox 3.5 and later