not compatible with 11.0 Rated 1 out of 5 stars

since updating Firefox, can't use the dictionary, not even with compatible tool , which was adviced by mozilla to install....HELP...realy used this tool a lot and miss it!!!

This review is for a previous version of the add-on (0.8.5).