Firefox 3 needed here! Rated 4 out of 5 stars

Please update for FF3, I must have this extension! :D

This review is for a previous version of the add-on (0.7.20080121.0).