Rated 5 out of 5 stars

I just mail to Steve few days ago and now he's going to submit a new version soon.

If you need a workable version with Firefox4 "NOW" , you could use the one I fork , and it will get in next official version.

Still a new fork version with Firefox4 support,
then I add scriptish support now.

http://files.tonyq.org/firefox/greasefire-1.0.4.4-fx.xpi

More details , please reference to
http://code.google.com/p/greasefire/issues/detail?id=20
http://code.google.com/p/greasefire/issues/detail?id=21

This review is for a previous version of the add-on (1.0.4).  This user has 4 previous reviews of this add-on.