Errors in FF 2.0 Rated 1 out of 5 stars

Totally buggy under FF2. Not recommended.

-=EDIT=-
Answering the developer: So you should change the allowed versions if it is not supposed to work in FF2!

This review is for a previous version of the add-on (2.1.1). 

Re: Errors in FF 2.0

It is not supposed to be working with FF2 - there is a separate version for FF2 available at https://addons.mozilla.org/en-US/developers/details/4618

Huji