Rated 4 out of 5 stars

Can anybody confirm that what they are telling is true? And please add extension for 3.6 and more proxy servers.

This review is for a previous version of the add-on (0.11).