Yes, it still works Rated 5 out of 5 stars

Works pefectly for me with FF18.0.1 (KDE 4.9.4, Ubuntu 12.10).