Thanks to Upgrade Version Rated 5 out of 5 stars

Today, I download Mozilla firefox 4.0. Than, I checked that old add on of Google Global is not working with Mozilla firefox 4.0. So, I just check for new version & happy to see that: New compatible version is available for Mozilla firefox 4.0. Thanks for your fast work!!

This review is for a previous version of the add-on (2.7.1-signed).