@NoriMori Rated 5 out of 5 stars

I'm aware of this. That's why I haven't announced this addon in 1-Click's page. I currently haven't had time to get FF4 to run here (I'm using a fairly old system, so I'll need to update it before installing FF4), so it may take a while until I fix this addon to work with it. I hope to get this done until the end of April, though.

EDIT: Fixed! Now it works with FF4.

This review is for a previous version of the add-on (1.5.2). 

Fixed!

Now it works with FF4.