Not FF 3.0.11 compatible ? Rated 1 out of 5 stars

This needs to be updated for Firefox 3.0.11 , so until then, I give this addon a thumbs down.