Great extension Rated 5 out of 5 stars

when I update my firefox from 3.6.28, I found this great extension, AeroBuddy is not capitable with fx 10.0 again

This review is for a previous version of the add-on (1.2.1).