Rated 3 out of 5 stars

3.6.7 causes a frequent java error, and it makes it so i can't even get all the warning messages closed. I had to load Firefox in safe-mode to uninstall it. Please update it for 3.6.7 Firefox.