same as others : update this Garmin !!!! Rated 1 out of 5 stars

no way to get this plugin fonctionnal.
Firefox, Chrome and Edge don't work with Windows 10 nor Linux Mint 17.2...
BUT it works with Internet Explorer 11 under Windows 10 ! Perhaps you should try Netscape with up-to-date Garmin plugins ! =/