48 reviews for this add-on
  • защо да е лесно,като може да е трудно ?
  • waarom laat Garmin de Firefox browser niet gebruiken voor deze extensie??? Slecht van hen.
  • Piece of digital junk. Doesn't seem to do anything at all.

    Hans van Helden
  • Garmin tut nichts, aber auch rein gar nichts, um die App mit Firefox Quantum kompatibel zu machen.
  • THE EXTENSION WAS A GOOD EXTENSION AND IT WOULD DOWNLOAD AND UPDATE YOUR GPS MAPS. THE PROBLEM IS THAT IT WON'T WORK WITH THE FIREFOX BROWSER BECAUSE THEY KEPT UPDATING FIREFOX BUT THE EXTENSION DIDN'T GET UPDATED AS FAST SO I COULD USE IT FOR THE INTENDED PURPOSE OF UPDATING MY GPS. I HAVE BEEN SO MADE WITH FIREFOX AND WISH THEY THEY COULD TELL GARMIN WHAT THEY NEED TO DO TO UPDATE THE EXTENSION TO WORK.

    PLEASE UPDATE GARMIN COMMUNICATOR.....
  • Echo ChelOis, Please update
  • Please update to the new Firefox 57+ technology.
  • :-(
  • So disappointed in Firefox for removing my ability to use my Garmin Communicator. The end user should get to decide what he/she wants to use....I thought this would solve that problem unfortunately it was false hope. I installed and restart as indicated and it didn't work, asked me to do it again, so a second time I repeated the DL and Restart only for a second failure... can someone fix this???!
  • Für Alle, bei denen es nicht funktioniert:
    RTFM: https://fly.garmin.com/fly-garmin/desktop/
  • I'd give Garmin a negative rating if it was available. Garmin fails to communicate with W10/W10.1. Running updates from Garmin and/or running suggested fixes is useless. Garmin blames MS but it is Garmin which is at fault not MS. NONE of my GPS units are recognized on my W10.1 machine but run just fine on a W7/8.1 machine. Problem has existed since DEC 2016. PATHETIC
  • with firefox 52 and 53 running on windows 10 it will not work. I have been "updating" from your site for months. How about fixing it.
  • Windows 10. Ich sehe das Plugin nur auf der Erweiterungenseite. Unter Plugins wird das nicht angezeigt. Der Hinweis von uku69 nutzt mir so garnicht.
  • Funktioniert jetzt problemlos (Windos10 und Firefox), dank dem Hinweis von uku69.
    Punktabzug gibt es wegen der irreführenden Hinweise, die beim Aufruf direkt aus einer Webseite kommen.
  • Dies ist eine Bewertung für das firefox add-on, das nicht geht. Würde gerne Geld für Erweiterungen ausgeben, Aber es geht auch nicht mit chrome, mit edge etc.
    Das add-on ist für windows 10 user nutzlos. Seit Windows 10 gibt es aber auch mit anderen Anwendungen Stress.
  • Hi folks,
    ich hab mich auch lange geärgert, dass das Garmin-Plugin im Firefox nicht mehr funzt und hab dann den Link auf diese Seite gefunden. Installiert, probiert, geht net.
    ABER - ich hab mich an was ähnliches erinnert beim Citrix-Plugin und die gleiche Strategie angewendet. Auf der Seite "Plugins" im Firefox kann man hinter dem Plugin angeben, wie das Plugin aktiviert werden soll. Da gibt es nie aktivieren, nachfragen und immer aktivieren. Mit der Einstellung "Immer aktivieren" kommt noch eine Nachfrage hoch, aber dann tut es wieder! Viel Erfolg allen genervten Cachern mit dieser hoffentlich auch bei Euch funktionierenden Lösung!
    For the english speaking: go to the plugin page, select the plugin & change the start option to "activate" (do not select "disable" & do not select "ask")
  • Ich bin sehr enttäuscht, dass das "Garmin Communicator Plugin" seit dem Wechsel auf Windows 10 von Firefox nicht mehr unterstäützt wird. Wirklich schade !!!
  • This plugin just does not work in Firefox. I could not get it working in other browsers too! How can you sell maps to people if they can not install it? Please get going and make it work. It is not rocket science...
  • no way to get this plugin fonctionnal.
    Firefox, Chrome and Edge don't work with Windows 10 nor Linux Mint 17.2...
    BUT it works with Internet Explorer 11 under Windows 10 ! Perhaps you should try Netscape with up-to-date Garmin plugins ! =/
  • Come on, Garmin! Get with it already!!! We need communicator updated and verified so we can continue to use it in Firefox!!!
  • Come on, we have paid you the money, so its your turn to give us the functioning software! Since this problem exists since June 2015, is this a project for the next three years?!

    >>Garmin Communicator-Plug-In installieren<<

    >>Bevor Sie fortfahren, müssen Sie die Version 4.1.0.0 des Garmin Communicator-Plug-Ins auf die Version 4.2.0.0aktualisieren.<<

    >>Die Installation ist kinderleicht. Auf der nächsten Seite finden Sie Schritt-für-Schritt-Anweisungen zur Installation<<
  • When trying to update my extras on my garmin, I get this message about the cruddy garmin plug in "To continue, you must update your Garmin Communicator Plugin from version 4.1.0.0 to version 4.2.0.0." Update your plugin you lazy mofos...wow.
  • Hundertmal installiert und .......
  • Hi Folks,

    I've discovered that Firefox must be set up to "Remember History" under Preferences -> Security select Remember History (Mac). If you're browsing privately or have things setup to delete cookies every time you close Firefox this plug-in won't work. I like to browse without history so I got everything working by allowing cookies to be installed until I got the plug-in working then I customized Firefox such that it kept the cookies from Garmin and deleted all others.
  • As other users mentioned - the add on, does not recognizes, that is already installed and so it reruns the installation again, again, again etc.
    So it's useless. If there is a workaround - please describe it.
Page 1 of 2