Perfect, but a little confusing for linux people Rated 5 out of 5 stars

After a bit of tinkering around, I finally got it to work on my Ubuntu 12.04 machine, and my god this is perfect, it's EXACTLY what I've been wanting for a while (I'm learning Japanese and I totally suck at anything to do with Kanji).

On the other hand, it was quite cumbersome to set up on Ubuntu and the instructions in the FAQs section helped but even after following that it still didn't work. In the end, I did some tinkering and found a much much much easier way than going through the steps in the add-on homepage and MeCab website to make this work on my Ubuntu machine.

So here's what I did:
- Installed the add-on for firefox
- Installed RUBY for firefox
- Downloaded and installed the furiganainserter-dictionary-<version>.7z (downloaded, unpacked, dragged and dropped into firefox)
- Installed the required MeCab UTF-8 dictionary -- this is where it got confusing for me but in the end, I found out that instead of downloading the MeCab packages from the website, following the instructions and running the 'make' command (which failed), all I had to do was run 'sudo apt-get install mecab-ipadic-utf8' and ubuntu took care of the rest for me. After that, just restarted firefox and everything worked, my struggles with kanji on the internet virtually ended.

So I hope that helps since when I was googling for help on installing this on ubuntu I couldn't find a whole lot of resources and I'm still a noob in the world of linux.

Seriously love this plug-in

This review is for a previous version of the add-on (2.0.13).