Rated 4 out of 5 stars

Initially I got in trouble when trying to activate this add-on, but after installing MeCab (there's a link on "support site/forum" ) it worked well. Thanks!

(SOLVED) Mecab is not working Rated 5 out of 5 stars

console.error:
Message: Error: Error: unsupported character set, only UTF-8 is supported: EUC-JP
Stack:
MecabWorker/this.worker.onerror@resource://furiganainserter/MecabWorker.js:23:23

EDIT: Thank you Zorkzero! The addon is working perfectly now

The error message tells you what you need to do. You need to install a mecab dictionary in UTF-8 format.

Still works, mostly Rated 4 out of 5 stars

You have to go to a lot of trouble to get it working on a Mac (install Homebrew, install MeCab via homebrew, copy and paste some lines of code, go into "about:config" on Firefox and allow it to run unsigned addons, restart Firefox...) but it still works as of September 2016 (Firefox version 48).

At first, changing the furigana to katakana or roman letters didn't work — it seems like this is only a problem if you use the context menu. If instead of right-clicking, you use the add-on logo on your add-on bar, it works (after messing around with it for a bit).

The "remove furigana" option in the right-click context menu actually removes all the KANJI on the page as well as the furigana. So it's best to not have the add-on be auto-activated, and to just refresh the page instead of hitting "remove furigana".

I'm also not sure if the method to make the furigana appear larger still works or not. It might work to set a (stylish) userstyle for all pages.

1. To switch the furigana alphabet for the current tab you have to use the drop down menu. The option in the settings is the default for new tabs.
2. I just went to wikipedia.jp and tested it. It worked perfectly. It may not work on some sites, but I didn't test it everywhere.
3. It still works in Fx 48.0.2.

Unsigned dictionary addon Rated 5 out of 5 stars

EDIT : Yeah you don't need that. On my system (Ubuntu 14.04) however, I could only get it to work by making it use the dictionary from the addon. mecab-ipadic from the repos didn't work. So it could be also be a mecab problem.

The inserter itself works perfectly though.

This part is obsolete, kept for archiving purposes
"Requires us to install the dictionary addon from the addon's homepage (on google code btw, which is read-only so idk where the real development is happening), which is unsigned. So can't install that (FF 43.0) without changing config, and so that renders this addon non-functional. (Haven't had the chance to use the addon so giving 3 stars; for a neutral score)"

This review is for a previous version of the add-on (2.12.1-signed.1-let-fixed). 

no need fo the dictionary addon

You don't need to install the dictionary addon you can also install MeCab. It's in the FAQ. If you need the dictionary addon then you can submit it to Mozilla for signing.

Wonderful! Made my life much easier Rated 5 out of 5 stars

I understand Japanese a little bit, but sometimes kanjis drive me crazy, now I can understand much better

This review is for a previous version of the add-on (2.12.1-signed.1-let-fixed). 

how do you do before the support for ruby Rated 5 out of 5 stars

hello,i have question
before the support for ruby tag by firefox,how do you put the kana above the kanji?

This review is for a previous version of the add-on (2.12.1-signed.1-let-fixed). 

Works wonderfully Rated 5 out of 5 stars

This extension is a life saver.
If it doesn't work for you, you may have forgot to install the required dictionary file from the extension home page.

This review is for a previous version of the add-on (2.12.1-signed.1-let-fixed). 

OK Rated 4 out of 5 stars

OK seems to works again for me.
Now need to check for memory usage.
This should help with reading the Japanese content.

This review is for a previous version of the add-on (2.10.1-signed). 

Ótimo complemento Rated 5 out of 5 stars

Faz exatamente o que diz fazer, ótimo para estudantes de japonês!

This review is for a previous version of the add-on (2.10.1-signed).