Rated 4 out of 5 stars

Its not compatible with FF 25.0.1