Rated 5 out of 5 stars

Love it - but it's incompatible with FF 3.07. Can we pretty please have an update with the outstanding bugs fixed? Thanks.

This review is for a previous version of the add-on (3.0.1).