Rated 5 out of 5 stars

Best ever but it does not work on FF 4.*

I reverted back to FF 3.6.* cause of this and few other add-ons.

Is there an ETA for FF 4.* compatible version?

This user has a previous review of this add-on.