Rated 5 out of 5 stars

Please, update it for Firefox 28-29 )))

This review is for a previous version of the add-on (10.1.3).  This user has a previous review of this add-on.

It is already compatible with Firefox 29.