Upgrade any theme all future versions Rated 5 out of 5 stars

download your theme. Don't worry about "...don't support mozilla xx" Save in a folder with "save link as" and then you have got the jar file. Open it with winrar, 7zip...look for the install.rdf file and extract it. Change the line like this "<em:maxVersion>17.*</em:maxVersion>. Close the file. If you see that appears another install.rdf file in the jar file delteit. Now, only left click and move your change install.rdf into the .jar file. End installing it like a thunderbird extension (install from folder) if you have any question feel free to ask me once again.

This review is for a previous version of the add-on (5.3.1). 

Thanks for helping users to upgrade by their own the compatibility, but you forgot to warn them that it doesn t mean that my themes will work totally correctly. It is a workaround but not a real solution. Try to do what you told with the 3.0.6 version of my Thunderbird theme and install it on Thunderbird 17... you ll see that TB17 is breaking lots of things that a simple compatibility upgrade can t solve. There is more job to do than what you are proposing so it could work correctly with the new changes brought by new Firefox and Thunderbird versions. I wouldn t like that your review misleads users and make them to think that there is just need to do what you told and everything is solved.
So again, it s nice you did this review, but don t forget to tell what can be the risks. Every Firefox and Thunderbird versions bring new features, new changes in design and to simply upgrade compatibility is not solving that...